#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<script[\s\S]+?/script>"
Local $sString = "<body>" & @CRLF & _
"<script src="...">" & @CRLF & _
"" & @CRLF & _
" </script>" & @CRLF & _
"<div onresize="CreateFixedHeaders()" onscroll="CreateFixedHeaders()" id="oReportDiv" style="overflow:auto;WIDTH:100%">" & @CRLF & _
"" & @CRLF & _
"<script type="text/javascript" language="javascript">" & @CRLF & _
"" & @CRLF & _
"//<![CDATA[" & @CRLF & _
"" & @CRLF & _
"function CreateFixedHeaders() {}//]]>" & @CRLF & _
"</script>" & @CRLF & _
"<script>" & @CRLF & _
"" & @CRLF & _
" var ClientReportfb64a4706a3749c484169e..." & @CRLF & _
" </script>" & @CRLF & _
"</body>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")