package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<script[\s\S]+?/script>`)
var str = `<body>
<script src="...">
</script>
<div onresize="CreateFixedHeaders()" onscroll="CreateFixedHeaders()" id="oReportDiv" style="overflow:auto;WIDTH:100%">
<script type="text/javascript" language="javascript">
//<![CDATA[
function CreateFixedHeaders() {}//]]>
</script>
<script>
var ClientReportfb64a4706a3749c484169e...
</script>
</body>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}