# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<script[\s\S]+?/script>"
test_str = ("<body>\n"
"<script src=\"...\">\n\n"
" </script>\n"
"<div onresize=\"CreateFixedHeaders()\" onscroll=\"CreateFixedHeaders()\" id=\"oReportDiv\" style=\"overflow:auto;WIDTH:100%\">\n\n"
"<script type=\"text/javascript\" language=\"javascript\">\n\n"
"//<![CDATA[\n\n"
"function CreateFixedHeaders() {}//]]>\n"
"</script>\n"
"<script>\n\n"
" var ClientReportfb64a4706a3749c484169e...\n"
" </script>\n"
"</body>")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.