#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(\S+).*?class="(?:\bschool\b.*?|.*?\bschool\b)".*?>(.+?)<\/\1>"
Local $sString = "<h1 class="school">Primary</h1>" & @CRLF & _
"<h1 class="school project">Secondary</h1>" & @CRLF & _
"<h2 class="project school">Primary</h2>" & @CRLF & _
"<h2 class="project school">Primary</h5>" & @CRLF & _
"<h3 class="schools project">Secondary</h3>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")