using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<(\S+).*?class=""(?:\bschool\b.*?|.*?\bschool\b)"".*?>(.+?)<\/\1>";
string input = @"<h1 class=""school"">Primary</h1>
<h1 class=""school project"">Secondary</h1>
<h2 class=""project school"">Primary</h2>
<h2 class=""project school"">Primary</h5>
<h3 class=""schools project"">Secondary</h3>";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}