import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\S+).*?class=\"(?:\\bschool\\b.*?|.*?\\bschool\\b)\".*?>(.+?)<\\/\\1>";
final String string = "<h1 class=\"school\">Primary</h1>\n"
+ "<h1 class=\"school project\">Secondary</h1>\n"
+ "<h2 class=\"project school\">Primary</h2>\n"
+ "<h2 class=\"project school\">Primary</h5>\n"
+ "<h3 class=\"schools project\">Secondary</h3>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}