using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?m)(?<=(?<!\\)(?:\\{0}))%.*(?:\r?\n(?!\r?$))?";
string input = @"\usepackage{test}%COMMENT1
TEXT
%COMMENT2
TEXT
Value is 10\%, this should not be removed. %COMMENT3
begin{tikz}[
important 1,
%COMMENT4
important 2, %COMMENT5
]
TEXT
%COMMENT 6
TEXT
Table: value1&value2\\%COMMENT7
Table: value1&value2\\ %COMMENT8
Table: value1&value2 \\%COMMENT 9
Table: value1&value2\\% COMMENT 10
Table: value1&value2\\\\%COMMENT11 ";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}