const regex = /(?m)(?<=(?<!\\)(?:\\{0}))%.*(?:\r?\n(?!\r?$))?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?m)(?<=(?<!\\\\)(?:\\\\{0}))%.*(?:\\r?\\n(?!\\r?$))?', 'gm')
const str = `\\usepackage{test}%COMMENT1
TEXT
%COMMENT2
TEXT
Value is 10\\%, this should not be removed. %COMMENT3
begin{tikz}[
important 1,
%COMMENT4
important 2, %COMMENT5
]
TEXT
%COMMENT 6
TEXT
Table: value1&value2\\\\%COMMENT7
Table: value1&value2\\\\ %COMMENT8
Table: value1&value2 \\\\%COMMENT 9
Table: value1&value2\\\\% COMMENT 10
Table: value1&value2\\\\\\\\%COMMENT11 `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}