# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?m)(?<=(?<!\\)(?:\\{0}))%.*(?:\r?\n(?!\r?$))?"
test_str = ("\\usepackage{test}%COMMENT1\n\n"
"TEXT\n"
"%COMMENT2\n"
"TEXT\n\n"
"Value is 10\\%, this should not be removed. %COMMENT3\n\n"
"begin{tikz}[\n"
"important 1,\n"
"%COMMENT4\n"
"important 2, %COMMENT5\n"
"]\n\n"
"TEXT\n"
"%COMMENT 6\n\n"
"TEXT\n\n"
"Table: value1&value2\\\\%COMMENT7\n"
"Table: value1&value2\\\\ %COMMENT8\n"
"Table: value1&value2 \\\\%COMMENT 9\n"
"Table: value1&value2\\\\% COMMENT 10\n"
"Table: value1&value2\\\\\\\\%COMMENT11 ")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.