import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)(?<=(?<!\\\\)(?:\\\\{0}))%.*(?:\\r?\\n(?!\\r?$))?";
final String string = "\\usepackage{test}%COMMENT1\n\n"
+ "TEXT\n"
+ "%COMMENT2\n"
+ "TEXT\n\n"
+ "Value is 10\\%, this should not be removed. %COMMENT3\n\n"
+ "begin{tikz}[\n"
+ "important 1,\n"
+ "%COMMENT4\n"
+ "important 2, %COMMENT5\n"
+ "]\n\n"
+ "TEXT\n"
+ "%COMMENT 6\n\n"
+ "TEXT\n\n"
+ "Table: value1&value2\\\\%COMMENT7\n"
+ "Table: value1&value2\\\\ %COMMENT8\n"
+ "Table: value1&value2 \\\\%COMMENT 9\n"
+ "Table: value1&value2\\\\% COMMENT 10\n"
+ "Table: value1&value2\\\\\\\\%COMMENT11 ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}