import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[^\"]*considerando|trabalho|social|providências|Réu:|Requerido:|Requerido\\(s\\):";
final String string = "CONSIDERANDO o poder constitucional conferido ao Ministério\n"
+ "Público de expedir notificação e requisições para instruir procedimentos\n"
+ "administrativos de sua competência;\n"
+ "CONSI2DERANDO que a Constituição Federal dispõe que \"A\n"
+ "assistência social será prestada a quem dela necessitar, independentemente\n"
+ "de contribuição à. Requerido(s): seguridade social, e tem por objetivos: I - a\n"
+ "proteção à família, à maternidade, à infância, à adolescência e à velhice;\n"
+ "II - o amparo às crianças e adolescentes carentes; III - a promoção da\n"
+ "integração. Requerido: ao mercado de trabalho:\" e\n"
+ "CONSI2DERANDO os elementos. Réu: contidos no Relatório de Auditoria\n"
+ "da Controladoria-Geral Réu: da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;\n"
+ "5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;\n"
+ "(Ministério do. Réu: Desenvolvimento Social e combate à Fome)\n"
+ "RESOLVE:\n"
+ "INSTAURAR o presente PROCEDIMENTO PREPARATÓRIO\n"
+ "Nº 03/2015, objetivando apurar as irregularidades apontadas no Relatório\n"
+ "de Auditoria da Controladoria-Geral da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;\n"
+ "5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;\n"
+ "determinando, desde já, que sejam adotadas as seguintes providências.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}