re = /[^"]*considerando|trabalho|social|providências|Réu:|Requerido:|Requerido\(s\):/
str = 'CONSIDERANDO o poder constitucional conferido ao Ministério
Público de expedir notificação e requisições para instruir procedimentos
administrativos de sua competência;
CONSI2DERANDO que a Constituição Federal dispõe que "A
assistência social será prestada a quem dela necessitar, independentemente
de contribuição à. Requerido(s): seguridade social, e tem por objetivos: I - a
proteção à família, à maternidade, à infância, à adolescência e à velhice;
II - o amparo às crianças e adolescentes carentes; III - a promoção da
integração. Requerido: ao mercado de trabalho:" e
CONSI2DERANDO os elementos. Réu: contidos no Relatório de Auditoria
da Controladoria-Geral Réu: da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;
5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;
(Ministério do. Réu: Desenvolvimento Social e combate à Fome)
RESOLVE:
INSTAURAR o presente PROCEDIMENTO PREPARATÓRIO
Nº 03/2015, objetivando apurar as irregularidades apontadas no Relatório
de Auditoria da Controladoria-Geral da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;
5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;
determinando, desde já, que sejam adotadas as seguintes providências.'
# Print the match result
str.match(re) do |match|
puts match.to_s
end