import re
regex = re.compile(r"[^\"]*considerando|trabalho|social|providências|Réu:|Requerido:|Requerido\(s\):")
test_str = ("CONSIDERANDO o poder constitucional conferido ao Ministério\n"
"Público de expedir notificação e requisições para instruir procedimentos\n"
"administrativos de sua competência;\n"
"CONSI2DERANDO que a Constituição Federal dispõe que \"A\n"
"assistência social será prestada a quem dela necessitar, independentemente\n"
"de contribuição à. Requerido(s): seguridade social, e tem por objetivos: I - a\n"
"proteção à família, à maternidade, à infância, à adolescência e à velhice;\n"
"II - o amparo às crianças e adolescentes carentes; III - a promoção da\n"
"integração. Requerido: ao mercado de trabalho:\" e\n"
"CONSI2DERANDO os elementos. Réu: contidos no Relatório de Auditoria\n"
"da Controladoria-Geral Réu: da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;\n"
"5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;\n"
"(Ministério do. Réu: Desenvolvimento Social e combate à Fome)\n"
"RESOLVE:\n"
"INSTAURAR o presente PROCEDIMENTO PREPARATÓRIO\n"
"Nº 03/2015, objetivando apurar as irregularidades apontadas no Relatório\n"
"de Auditoria da Controladoria-Geral da União nos itens 5.1.1.; 5.1.2.; 5.1.3.;\n"
"5.1.6.; 5.1.7.; 5.1.8.; 5.1.10. 5.2.1.; 5.2.2.; 5.2.3.; 5.3.2.; 5.3.5. e 5.3.9;\n"
"determinando, desde já, que sejam adotadas as seguintes providências.")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")