import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^AI]+|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^D]|$)|ABCD(?:[^E]|$)|ABCDE(?:[^F]|$))|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^H]|$)|ABCH(?:[^I]|$)|ABCHI(?:[^J]|$)))$";
final String string = "ABCD\n"
+ "ABCDEF\n"
+ "EFGH\n"
+ "IJKL\n"
+ "MNOP\n"
+ "ABCHIJ\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}