// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"^(?:[^AI]+|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^D]|$)|ABCD(?:[^E]|$)|ABCDE(?:[^F]|$))|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^H]|$)|ABCH(?:[^I]|$)|ABCHI(?:[^J]|$)))$").unwrap();
let string = "ABCD
ABCDEF
EFGH
IJKL
MNOP
ABCHIJ
";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}