$re = '/^(?:[^AI]+|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^D]|$)|ABCD(?:[^E]|$)|ABCDE(?:[^F]|$))|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^H]|$)|ABCH(?:[^I]|$)|ABCHI(?:[^J]|$)))$/';
$str = 'ABCD
ABCDEF
EFGH
IJKL
MNOP
ABCHIJ
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);