import re
regex = re.compile(r"^(?:[^AI]+|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^D]|$)|ABCD(?:[^E]|$)|ABCDE(?:[^F]|$))|(?:A(?:[^B]|$)|AB(?:[^C]|$)|ABC(?:[^H]|$)|ABCH(?:[^I]|$)|ABCHI(?:[^J]|$)))$")
test_str = ("ABCD\n"
"ABCDEF\n"
"EFGH\n"
"IJKL\n"
"MNOP\n"
"ABCHIJ\n")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")