using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"app/(\d+)/(\d+)/(\w+)|app/(\d+)/(\d+)/|app/(\d+)/(\w+)|app/(\d+)/|app/(\w+)|app";
string input = @"app/1/2/foo
app/1/2/
app/1/bar
app/1/
app/bar
app/";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}