import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "app/(\\d+)/(\\d+)/(\\w+)|app/(\\d+)/(\\d+)/|app/(\\d+)/(\\w+)|app/(\\d+)/|app/(\\w+)|app";
final String string = "app/1/2/foo\n"
+ "app/1/2/\n"
+ "app/1/bar\n"
+ "app/1/\n"
+ "app/bar\n"
+ "app/";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}