re = /app\/(\d+)\/(\d+)\/(\w+)|app\/(\d+)\/(\d+)\/|app\/(\d+)\/(\w+)|app\/(\d+)\/|app\/(\w+)|app/
str = 'app/1/2/foo
app/1/2/
app/1/bar
app/1/
app/bar
app/'
# Print the match result
str.match(re) do |match|
puts match.to_s
end