const regex = new RegExp('app/(\\d+)/(\\d+)/(\\w+)|app/(\\d+)/(\\d+)/|app/(\\d+)/(\\w+)|app/(\\d+)/|app/(\\w+)|app', '')
const str = `app/1/2/foo
app/1/2/
app/1/bar
app/1/
app/bar
app/`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}