#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(20[0-9]{0,2})[\-_]?([01]?[0-9])[\-_]?([0123]?[0-9])"
Local $sString = "2017-01-01" & @CRLF & _
"2018-05-15-project1.backup.tar" & @CRLF & _
"projekt2-2018-05-15.tgz.part01.enc" & @CRLF & _
"projekt3-20170913.tar.gz" & @CRLF & _
"projekt3-2017_09_13.tar.gz"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")