using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(20[0-9]{0,2})[\-_]?([01]?[0-9])[\-_]?([0123]?[0-9])";
string input = @"2017-01-01
2018-05-15-project1.backup.tar
projekt2-2018-05-15.tgz.part01.enc
projekt3-20170913.tar.gz
projekt3-2017_09_13.tar.gz";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}