$re = '/(20[0-9]{0,2})[\-_]?([01]?[0-9])[\-_]?([0123]?[0-9])/m';
$str = '2017-01-01
2018-05-15-project1.backup.tar
projekt2-2018-05-15.tgz.part01.enc
projekt3-20170913.tar.gz
projekt3-2017_09_13.tar.gz';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);