// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(20[0-9]{0,2})[\-_]?([01]?[0-9])[\-_]?([0123]?[0-9])").unwrap();
let string = "2017-01-01
2018-05-15-project1.backup.tar
projekt2-2018-05-15.tgz.part01.enc
projekt3-20170913.tar.gz
projekt3-2017_09_13.tar.gz";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}