#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:\d{2})?(?:[6-9]\d{7}|9\d{8})$"
Local $sString = "4133333321" & @CRLF & _
"85430897" & @CRLF & _
"90761345" & @CRLF & _
"1990461345" & @CRLF & _
"5544444444" & @CRLF & _
"24505678" & @CRLF & _
"41987456876" & @CRLF & _
"97644356" & @CRLF & _
"99991111" & @CRLF & _
"58753201" & @CRLF & _
"67890431" & @CRLF & _
"999999999" & @CRLF & _
"78906542" & @CRLF & _
"83567031" & @CRLF & _
"5568795527" & @CRLF & _
"4559853212" & @CRLF & _
"45678901" & @CRLF & _
"23456790" & @CRLF & _
"5140041000" & @CRLF & _
"5535489574" & @CRLF & _
"7899504526"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")