import Foundation
let pattern = #"^(?:\d{2})?(?:[6-9]\d{7}|9\d{8})$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
4133333321
85430897
90761345
1990461345
5544444444
24505678
41987456876
97644356
99991111
58753201
67890431
999999999
78906542
83567031
5568795527
4559853212
45678901
23456790
5140041000
5535489574
7899504526
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)