import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:\\d{2})?(?:[6-9]\\d{7}|9\\d{8})$";
final String string = "4133333321\n"
+ "85430897\n"
+ "90761345\n"
+ "1990461345\n"
+ "5544444444\n"
+ "24505678\n"
+ "41987456876\n"
+ "97644356\n"
+ "99991111\n"
+ "58753201\n"
+ "67890431\n"
+ "999999999\n"
+ "78906542\n"
+ "83567031\n"
+ "5568795527\n"
+ "4559853212\n"
+ "45678901\n"
+ "23456790\n"
+ "5140041000\n"
+ "5535489574\n"
+ "7899504526";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}