re = /^(?:\d{2})?(?:[6-9]\d{7}|9\d{8})$/m
str = '4133333321
85430897
90761345
1990461345
5544444444
24505678
41987456876
97644356
99991111
58753201
67890431
999999999
78906542
83567031
5568795527
4559853212
45678901
23456790
5140041000
5535489574
7899504526'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end