import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([0-9]{2}\\) 9?[0-9]{4}-[0-9]{4}";
final String string = "(11) 33333321\n"
+ "(11) 8543-0897\n"
+ "(11) 99076-1345\n"
+ "(11) 9046 -1345\n"
+ "(11) 2450 -5678\n"
+ "(11) 9764-4356\n"
+ "(11) 99991111\n"
+ "(11) 58753201\n"
+ "(11) 67890431\n"
+ "(11) 999999999\n"
+ "(11) 78906542\n"
+ "(11) 83567031\n"
+ "(11) 09853212\n"
+ "(11) 45678901\n"
+ "(11) 23456790\n"
+ "(11) 4004-1000";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}