import re
regex = re.compile(r"\([0-9]{2}\) 9?[0-9]{4}-[0-9]{4}", flags=re.MULTILINE)
test_str = ("(11) 33333321\n"
"(11) 8543-0897\n"
"(11) 99076-1345\n"
"(11) 9046 -1345\n"
"(11) 2450 -5678\n"
"(11) 9764-4356\n"
"(11) 99991111\n"
"(11) 58753201\n"
"(11) 67890431\n"
"(11) 999999999\n"
"(11) 78906542\n"
"(11) 83567031\n"
"(11) 09853212\n"
"(11) 45678901\n"
"(11) 23456790\n"
"(11) 4004-1000")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")