re = /\([0-9]{2}\) 9?[0-9]{4}-[0-9]{4}/m
str = '(11) 33333321
(11) 8543-0897
(11) 99076-1345
(11) 9046 -1345
(11) 2450 -5678
(11) 9764-4356
(11) 99991111
(11) 58753201
(11) 67890431
(11) 999999999
(11) 78906542
(11) 83567031
(11) 09853212
(11) 45678901
(11) 23456790
(11) 4004-1000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end