package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\(*\d{2}\)*\s*[6|7|8|9](?:\d{7}|\d{3}\s*-\s*\d{4})$`)
var str = `1133333321
41 8543-0897
119076-1345
(21)9046 -1345
2450 -5678
9764-4356
2199991111
(51)58753201
(57)67890431
999999999
78906542
83567031
09853212
45678901
23456790
40041000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}