# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^\(*\d{2}\)*\s*[6|7|8|9](?:\d{7}|\d{3}\s*-\s*\d{4})$"
test_str = ("1133333321\n"
"41 8543-0897\n"
"119076-1345\n"
"(21)9046 -1345\n"
"2450 -5678\n"
"9764-4356\n"
"2199991111\n"
"(51)58753201\n"
"(57)67890431\n"
"999999999\n"
"78906542\n"
"83567031\n"
"09853212\n"
"45678901\n"
"23456790\n"
"40041000")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.