use strict;
my $str = '1133333321
41 8543-0897
119076-1345
(21)9046 -1345
2450 -5678
9764-4356
2199991111
(51)58753201
(57)67890431
999999999
78906542
83567031
09853212
45678901
23456790
40041000';
my $regex = qr/^\(*\d{2}\)*\s*[6|7|8|9](?:\d{7}|\d{3}\s*-\s*\d{4})$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}