re = /.*\s(?<Memory>.\d*)\s(?<Cpu>.\d*)\s(?<Truc>[^\s+]*)/
str = '20160607-10:27:01 427369444501 14445 2.9788888 37.1'
subst = ''
result = str.sub(re, subst)
# Print the result of the substitution
puts result