import Foundation
let pattern = #".*\s(?<Memory>.\d*)\s(?<Cpu>.\d*)\s(?<Truc>[^\s+]*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"20160607-10:27:01 427369444501 14445 2.9788888 37.1"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}