# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/.*?https?:\/\/(?:www\.)?google\.com\/([^&]+)&.*/\1/s;t' <<< "http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&"