$re = '~.*?https?://(?:www\.)?google\.com/([^&]+)&.*~s';
$str = 'http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&';
$subst = "\1";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;