using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*?https?://(?:www\.)?google\.com/([^&]+)&.*";
string substitution = @"\1";
string input = @"http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}