use strict;
my $str = 'http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&';
my $regex = qr~.*?https?://(?:www\.)?google\.com/([^&]+)&.*~sp;
my $subst = '\\1';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";