#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?s).*?https?://(?:www\.)?google\.com/([^&]+).*"
Local $sString = "http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&"
Local $sSubst = "\1"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)