re = /.*?https?:\/\/(?:www\.)?google\.com\/([^&]+).*/
str = 'http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&'
subst = '\\1'
result = str.sub(re, subst)
# Print the result of the substitution
puts result