const regex = new RegExp('.*?https?://(?:www\\.)?google\\.com/([^&]+).*', 's')
const str = `http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&`;
const subst = `\1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);