// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?s).*?https?://(?:www\.)?google\.com/([^&]+).*").unwrap();
let string = "http://www.google.com/search?q=erykah+badu+with+hiatus+kaiyote,+august+3&";
let substitution = "\\1";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}