import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^;([^;]+);.*?\\n[^;]+;(?!\\1)([^;]+)";
final String string = ";TEXT;2;34;1;0;;;;;;3200;\n"
+ "PRINT_Polohopis.dgn;Different TEXT;2;64;1;0;;;;;;3200;";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}