re = /^;([^;]+);.*?\n[^;]+;(?!\1)([^;]+)/
str = ';TEXT;2;34;1;0;;;;;;3200;
PRINT_Polohopis.dgn;Different TEXT;2;64;1;0;;;;;;3200;'
# Print the match result
str.match(re) do |match|
puts match.to_s
end