import re
regex = re.compile(r"^;([^;]+);.*?\n[^;]+;(?!\1)([^;]+)")
test_str = (";TEXT;2;34;1;0;;;;;;3200;\n"
"PRINT_Polohopis.dgn;Different TEXT;2;64;1;0;;;;;;3200;")
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")