const regex = /^;([^;]+);.*?\n[^;]+;(?!\1)([^;]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^;([^;]+);.*?\\n[^;]+;(?!\\1)([^;]+)', '')
const str = `;TEXT;2;34;1;0;;;;;;3200;
PRINT_Polohopis.dgn;Different TEXT;2;64;1;0;;;;;;3200;`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}