package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(<a.*?href="//.*?">.*?</a>)|(<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>)`)
var str = `dqwqwfqfewf fwefwef fwe fw fwefwefwe
fwefwefwefwefwefwefwefwef fwef.
<a href="/dwdw.php/">dwdqwdqwd</a>
fwefwefwefwefewfwefwefwefwfwefwefwefwefwefew.
<a href="http://site.ru" class="link_external"><span class="link_text">Заголовок</span></a>
dqwqwfqfewf fwefwef fwe fw fwefwefwe
<a href="//dwdw.php">dwdqwdqwd</a>
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}